The site is currently undergoing some upgrades on the backend. You won’t exactly see any improvements out here as it namely optimizing queries, code and cutting down on functions queries on the pages in line of the of my upgrade to the latest version of MySQL and WordPress as well, which comes with a whole new set of available queries and plugins which need updating as well.

I’ve noticed that when scrolling the pages on my slower computers, the pages move rather jerkily, maybe due to the slow loading of ads on my pages. I’ve removed some ads from my blog pages which accounts for more than 50% of the pages of the site as they are also seriously slowing down the loading of my pages in internet explorer (mozilla still loads the pages rather well) but considering about more than 60% of my visitors use IE, it’s an exception I have to take. I am still in the mist of trying out various advert placement and sizes so my pages won’t be so cluttered, so please don’t be alarmed if you see an ad placed where it isn’t normally is.

I will be also bumping up the cache and memory allocation of the pages to cater for the large number of visitors to the site. A pleasant site experience for my users is still my priority over my advertisers.

Will be monitoring the pages over the next few days for bugs, do report any if you see them!

4 COMMENTS

  1. While you are at there, you can use feedburner.com to keep track of RSS feed subscribers. I am one of them =D

    Upgrading WP is a hassale, that is why my main site is still on 1.5.2. My next version that I am going to do will be WP 2.x and hopefully I can launched it during my summer break.

    I have been doing it since last summer break, but too lazy and things never get done as it is really a lot of work between WP 1.5 and WP 2.x

    • Yup, there are alot of incompatible DB queries which are not registered in 2.3.X. And alot of plugins needs to be upgraded. The new admin interface is rather quirky too- also alot of my usability hacks in 1,5 needs to be re-coded to the new interface.

      But what I like is that alot of functions (such as stats) are already inbuilt, so I can simply just call from there and cut down on my function list.

      1.5.2… This means your host is still running MySQL < V5.0.51? take note when upgrading up as it not compatible with previous version of wordpress (1.5) as well.

  2. I am on my own host together with my friends, http://frro.net. MYSQL is 5.0.37. MYSQL compatibility issue is not much of a problem so far (at least I have not encountered any yet). It is more of a WP core changes from 1.5 to 2.3, it is lots of changes, a lot of stuffs cannot work any more in 2.3 as it is more secure. Have to get pass it.

    • Mmm I’ve seen the core changes, but the good thing is alot of things like template tags, etc are all still compatible, it’s the plugin part which got quite alot of changes right?

      Cool, so ya run ya own box or in a datacenter? I have a group as well who hosts our boxes in the Singapore datacenter (comm center) for company biz webhosting as well. So many people are doing this now, it’s like quick easy cash haha.

LEAVE A REPLY

Please enter your comment!
Please enter your name here